【漏洞预警】Kubernetes API服务器远程特权提升漏洞

2018年12月04日,Kubernetes官方发布安全通告,披露了一个Kubernetes API服务器特权提升漏洞CVE-2018-1002105。

漏洞描述
通过特制请求,未经身份验证的恶意用户可以通过Kubernetes API服务器与后端服务器(例如聚合API服务器和kubelets)建立连接,然后通过同一连接将任意请求直接发送到后端,并使用Kubernetes API服务器用于建立后端连接的TLS凭证进行身份验证。进而可以窃取敏感数据或注入恶意代码,甚至控制Kubernetes集群。

影响组件
Kubernetes API server

影响版本
Kubernetes v1.0.x-1.9.x
Kubernetes v1.10.0-1.10.10
Kubernetes v1.11.0-1.11.4
Kubernetes v1.12.0-1.12.2

安全版本
Kubernetes v1.10.11
Kubernetes v1.11.5
Kubernetes v1.12.3
Kubernetes v1.13.0-rc.1

风险评级:
CVE-2018-1002105 严重

安全建议:升级Kubernetes至安全版本。

相关链接
https://access.redhat.com/security/vulnerabilities/3716411
https://groups.google.com/forum/#!topic/kubernetes-announce/GVllWCg6L88
https://github.com/kubernetes/kubernetes/issues/71411


华云数据集团有限公司
2018年12月05日